If you do not, there is a risk of a version skew occurring that can lead to unexpected, buggy behaviour. However, one minor version skew between the kubelet and the control plane is supported, but the kubelet version may never exceed the API server version. For example, kubelets running 1.7.0 should be fully compatible with a 1.8.0 API server ...
Apr 10, 2018 · AWS acquiesced to the inevitable in 2017 -- with a partnership to run VMware Cloud on AWS and then with Elastic Container Service for Kubernetes (EKS), a managed high availability cluster service that runs the latest version open source Kubernetes.